Αρχές Προγραμματισμού

Αλγόριθμοι, Αλγοριθμικές δομές

Αλγόριθμοι

Αλγόριθμος είναι μια σειρά πεπερασμένων ενεργειών καθορισμένων και εκτελέσιμων σε πεπερασμένο χρόνο, που στοχεύουν στην επίλυση ενός προβλήματος. Κάθε αλγόριθμος απαραίτητα ικανοποιεί τα επόμενα κριτήρια.

Για να μπορέσουμε να συντάξουμε έναν αλγόριθμο σε μορφή κώδικα, οποιαδήποτε γλώσσα και αν χρησιμοποιήσουμε απαραίτητα είναι:

Σταθερές (constants)

Με τον όρο αυτό αναφερόμαστε σε προκαθορισμένες τιμές που παραμένουν αμετάβλητες σε όλη τη διάρκεια της εκτέλεσης ενός αλγορίθμου.
Οι σταθερές μπορεί να είναι:

Μεταβλητές (variables)

Μια μεταβλητή είναι μια θέση στη μνήμη η οποία περιέχει μια τιμή και στην οποία έχουμε αντιστοιχίσει ένα όνομα.
Οι μεταβλητές μπορεί να είναι:

Τελεστές (operators)

Πρόκειται για τα γνωστά σύμβολα που χρησιμοποιούνται στις διάφορες πράξεις.

Εκφράσεις (expressions)

Οι εκφράσεις διαμορφώνονται από τους τελεστέους (operands), που είναι σταθερές και μεταβλητές και από τους τελεστές. Η τελική τιμή μιας έκφρασης εξαρτάται από την ιεραρχία των πράξεων και τη χρήση των παρενθέσεων.

Δομή ακολουθίας

Η ακολουθιακή δομή εντολών (σειριακών βημάτων) χρησιμοποιείται πρακτικά για την αντιμετώπιση απλών προβλημάτων,όπου είναι δεδομένη η σειρά εκτέλεσης ενός συνόλου ενεργειών.

Παράδειγμα 1: Να διαβασθούν δύο αριθμοί, να υπολογισθεί και να εκτυπωθεί το άθροισμα τους.
Αλγόριθμος Παράδειγμα_1
Διάβασε α
Διάβασε b
c ← a+b
Εκτύπωσε c
Τέλος Παράδειγμα_1

Δομή επιλογής

H διαδικασία της επιλογής περιλαμβάνει τον έλεγχο κάποιας συνθήκης που μπορεί να έχει δύο τιμές (Αληθής ή Ψευδής) και ακολουθεί η απόφαση εκτέλεσης κάποιας ενέργειας με βάση την τιμή της λογικής αυτής συνθήκης.

Αν συνθήκη τότε
εντολή ή εντολές
αλλιώς_αν συνθήκη τότε
εντολή ή εντολές
αλλιώς
εντολή ή εντολές
Τέλος_αν
Παράδειγμα 2. Να διαβαστεί ένας αριθμός και να εκτυπωθεί η απόλυτη τιμή του.

Αλγόριθμος Παράδειγμα_2

Διάβασε a

Αν a < 0 τότε a←a*(-1)

Εκτύπωσε a

Τέλος Παράδειγμα_2 

Δομή επανάληψης

Η διαδικασία της επανάληψης είναι ιδιαίτερα συχνή, αφού πλήθος προβλημάτων μπορούν να επιλυθούν με κατάλληλες επαναληπτικές διαδικασίες. Η λογική των επαναληπτικών διαδικασιών εφαρμόζεται στις περιπτώσεις, όπου μία ακολουθία εντολών πρέπει να εφαρμοσθεί σε ένα σύνολο περιπτώσεων, που έχουν κάτι κοινό.

Όσο συνθήκη επανάλαβε
εντολές
Τέλος_επανάληψης
Για μεταβλητή από τ1 μέχρι τ2 με_βήμα β 
εντολές
Τέλος_επανάληψης

Δομή επανάληψης

  Αλγόριθμος Παράδειγμα_3 
a←0
i←1
Όσο i≤10 επανάλαβε
a←a+i
i←i+1
Τέλος_επανάληψης
Εκτύπωσε a
Τέλος Παράδειγμα_3
 Αλγόριθμος Παράδειγμα_4
a←0
Για i απο 1 μέχρι 10 με_βήμα 1 επανάλαβε
a←a+i
Τέλος_επανάληψης
Εκτύπωσε a
Τέλος Παράδειγμα_4

Εντολές εισόδου/εξόδου στο Matlab

input('κείμενο που θα εμφανιστεί')  :η εντολή για να εισάγει ο χρήστης τιμή απο το πληκτρολόγιο (Διάβασε)
disp(όνομα μεταβλητής ή 'κείμενο') :η εντολή για να εκτυπωθεί μια τιμή στο command window (Εκτύπωσε)
Παράδειγμα 5 - Διαβάζει απο το πληκτρολόγιο 2 αριθμούς και εκτυπώνει το άθροισμα τους.
x = input('x:')   Διαβάζει μια τιμή και την αποθηκεύει στη μεταβλητή x
y = input('y:')	  Διαβάζει μια τιμή και την αποθηκεύει στη μεταβλητή y
z=x+y;			  Αθροίζει το x και το y
disp('z:') 		  Τυπώνει το κείμενο z:
disp(z)			  Τυπώνει την τιμή της μεταβλητής z

/